¿Cuales son las características del servicio Ruby que ofrecéis?

Nuestros servicio de hosting para Ruby es uno de los mejores del mercado, ofreciendo un buen rendimiento y una flexibilidad sin igual.

Características generales

  • Ofrecemos Ruby usando Passenger sobre Apache, que da un buen rendimiento y estabilidad.
  • Puedes elegir entre 8 stacks Ruby diferentes
  • No hay gemas preinstaladas, pero tu mismo puedes instalar casi cualquier gema.
  • Cualquier gema que instales será accesible a todas las aplicaciones alojadas en la misma cuenta de hosting.
  • Soporte para todas las versiones de Rails que van desde la 2.3 a la 5.x

5 stacks Ruby a elegir

Todos de nuestros planes de hosting y cuentas de hosting bajo planes revendedor pueden usar cualquiera de los stack Ruby que ofrecemos, pero solo pueden usar un stack por hosting. Es decir, en un mismo hosting no se puede tener aplicaciones que hagan uso de diferentes stack. Se pueden tener varias aplicaciones que usen el mismo stack.

Los stack se diferencian por la versión de Ruby y Rubygems que incorporan:

  • Ruby 2.6: Ruby 2.6 y Rubygems 3.0.x
  • Ruby 2.5: Ruby 2.5 y Rubygems 2.7.x
  • Ruby Fox: Ruby 2.4 y Rubygems 2.6.x
  • Ruby Tux: Ruby 2.3 y Rubygems 2.6.x
  • Ruby Kon: Ruby 2.2 y Rubygems 2.4.x
  • Ruby Hai: Ruby 2.1 y Rubygems 2.2.x
  • Ruby Lur: Ruby 1.9 y Rubygems 1.8.x
  • Ruby Sua: Ruby 1.8.7 y Rubygems 1.5.x

Cada stack tiene su lugar. Por ejemplo, el stack Ruby Sua nos permite dar soporte a aplicaciones antiguas y dificiles de actualizar, mientrás que los stack Ruby 2.5 y 2.6 ponen a tu disposición lo mejor y más nuevo.

Características específicas de cada Stack

Ruby 2.6

Las características principales del stack Ruby 2.5 se pueden resumir en:

  • Ruby 2.6.
  • La versión de Rubygems es 3.0.x
  • Perfecto para Rails 5.2

Ruby 2.5

Las características principales del stack Ruby 2.5 se pueden resumir en:

  • Ruby 2.5.
  • La versión de Rubygems es 2.7.x
  • Perfecto para Rails 5.2

 

 

Ruby Fox

Las características principales del stack Ruby Fox se pueden resumir en:

  • Ruby 2.4.
  • La versión de Rubygems es 2.6.x
  • El más adecuado para Rails 5.1

Ruby Tux

Las características principales del stack Ruby Fox se pueden resumir en:

  • Ruby 2.3.
  • La versión de Rubygems es 2.6.x
  • Soporta Rails 3, 4 y 5

Ruby Kon

Las características principales del stack Ruby Kon se pueden resumir en:

  • Ruby 2.2.
  • La versión de Rubygems es 2.4.x
  • Soporta Rails 3, 4 y 5

Ruby Hai

Las características principales del stack Ruby Hai se pueden resumir en:

  • Ruby 2.1.
  • La versión de Rubygems es 2.2.x
  • Soporta Rails 3 y 4

Ruby Lur

Las características principales del stack Ruby Lur se pueden resumir en:

  • Ruby 1.9.3.
  • La versión de Rubygems es 1.8.x
  • Soporta Rails 2 y 3

Ruby Sua

Las características principales del stack Ruby Sua se pueden resumir en:

  • Ruby 1.8.7, concretamente la variante Ruby Enterprise.
  • La versión de Rubygems es la 1.5.x
  • Soportamos Rails 2 y 3, hasta la versión 3.2. Las versiones superiores no son compatibles con Ruby 1.8.