Como elegir la versión de PHP

9 de Septiembre, 2015 @ 16:36 — 0 comentarios

Actualmente, Junio del 2016, la versión de PHP prederterminada es la 5.5, pero ofrecemos varias versiones adicionales (7.1, 7.0, 5.6, 5.5, 5,3, ..) y podéis elegir la que necesitéis.

En nuestros planes de hosting, revendedor y servidores Cloud Premium podéis elegir la versión de PHP que queréis utilizar en cada dominio, subdominio o carpeta. Y hay 2 formas de hacerlo.

Elegir la versión desde el panel de Hosting

Este es el método más cómodo y rápido para la mayoría de usuarios, aunque solo permite elegir la versión de PHP en dominios y subdominios: si quieres una versión de PHP diferente en una carpeta, tendrás que usar el segundo método.

1 - Accede al Panel de Hosting

Sigue las indicaciones de nuestra guía Como acceder al Panel de Hosting.

2 - Accede al apartado Configuración de PHP

Una vez estes dentro del Panel de Hosting haz click en el icono Configuración de PHP.

hosting-configuracion-php-1

3 - Elige la versión modificando el selector

Ubica el dominio o subdominio cuya versión de PHP quieres cambiar, selecciona la versión deseada en el sector y listo.

hosting-configuracion-php-2

Elegir la versión vía SSH

1 - Accede a tu hosting mediante SSH

Sigue las indicaciones de la guía Como acceder vía SSH a tu cuenta.

2 - Cambia al directorio del dominio o subdominio

Debes cambiar al directorio del dominio o subdominio donde desees hacer el cambio de versión de PHP.

Por ejemplo, si quieres definir la versión PHP del dominio principal del hosting, tendrás que entrar al directorio public_html :

cd public_html

Si no tienes claro cual es el directorio donde debes aplicar el cambio, en el icono Configuración PHP del Panel de Hosting se muestra el directorio ráiz de todos tu dominios y subdominios.

3 - Edita el archivo .htaccess

Una vez estas ubicado en el directorio donde quieres elegir la versión de PHP, debes abrir el archivo .htaccess y añadir una simple línea de configuración.

Para abrir el archivo .htaccess puedes usar los editores nano o vi, por ejemplo:

nano .htaccess

Si quieres usar la versión 7.1 de PHP, debes añadir la siguiente línea:

AddHandler php7.1-script .php

Si quieres usar la versión 7.0 de PHP, debes añadir la siguiente línea:

AddHandler php7.0-script .php

Si quieres usar PHP 5.6:

AddHandler php5.6-script .php

Si quieres usar PHP 5.5:

AddHandler php5.5-script .php

Para usar PHP 5.4:

AddHandler php5.4-script .php

Para usar PHP 5.3:

AddHandler php5.3-script .php

Para usar PHP 5.2:

AddHandler php5-script .php

Ten en cuenta que el archivo .htaccess puede existir o no; y si existe, puede tener mucho contenido, asegurate de no borrar nada.

Etiquetas: